Uploaded image for project: 'MusicBrainz Server'
  1. MusicBrainz Server
  2. MBS-6999

Perl Dependency Clarification

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Database setup
    • Labels:
      None

      Description

      INSTALL.md states you need Perl 5.10.1+ but Makefile.PL contains a dependency for Sys::Hostname 1.16 (and also says use Perl 5.8.8) which from what I can gather was shipped with Perl 5.16.3. I'm trying to install MBS on a system with Perl 5.10.1 but cpanm chokes on Sys::Hostname.

      If the minimum Perl version has increased, could the documentation be updated?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jseet Jonathan Seet
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Packages

                Version Package