Uploaded image for project: 'Picard'
  1. Picard
  2. PICARD-1065

python setup.py patch_version doesn't work

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.0.4dev1
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:
      None

      Description

      ↪ python setup.py patch_version
      running patch_version
      Traceback (most recent call last):
      File "setup.py", line 781, in <module>
      setup(**args)
      File "/usr/lib/python3.6/distutils/core.py", line 148, in setup
      dist.run_commands()
      File "/usr/lib/python3.6/distutils/dist.py", line 955, in run_commands
      self.run_command(cmd)
      File "/usr/lib/python3.6/distutils/dist.py", line 974, in run_command
      cmd_obj.run()
      File "setup.py", line 583, in run
      self.patch_version('picard/_init_.py')
      File "setup.py", line 590, in patch_version
      patched_source = regex.sub('PICARD_BUILD_VERSION_STR = "%s"' % build, source)
      TypeError: cannot use a string pattern on a bytes-like object

        Attachments

          Activity

            People

            • Assignee:
              samj1912 Sambhav Kothari
              Reporter:
              mineo Wieland Hoffmann
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: