Uploaded image for project: 'Picard'
  1. Picard
  2. PICARD-1614

macOS: Incorrect 'LSMinimumSystemVersion'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.1
    • Fix Version/s: 2.2.2
    • Component/s: Packaging & Deployment
    • Labels:
      None
    • Environment:
      macOS

      Description

      MusicBrainz Picard 2.2 has raised the macOS minimum system requirements to macOS 10.12. While you've noted the new system requirements on the homepage, you've forgot to actually update the real binary system requirements embedded into the app.

      the 'LSMinimumSystemVersion' entry in your Info.plist file should be set to 10.12

       

      as it is currently, you can still launch the app on any older operating system, resulting in crashes and/or undefined behaviour, and the user might not even know what the problem is. properly setting the LSMinimumSystemVersion will make the app refuse to launch on any macOS version that is not new enough,

        Attachments

          Activity

            People

            Assignee:
            outsidecontext Philipp Wolfer
            Reporter:
            dinkblam julian
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Packages

                Version Package
                2.2.2