Fix Timescale DB setup in manage.py

XMLWordPrintable

    • Type: Bug
    • Resolution: Fixed
    • Priority: Normal
    • None
    • Component/s: data store
    • None

      The command

      ./develop.sh manage init_ts_db -f
      

      throws an error 

      sqlalchemy.exc.OperationalError: (psycopg2.OperationalError) FATAL: password authentication failed for user "timescale_lb"
      

      This might be due to the reason that on running the above command it runs the queries in admin.timescale.drop_db.sql which also drops the timescale_lb user. The timescale_lb  user gets created during execution of the following code and queries but no password is associated with it.

      This can be tackled by running the queries in admin.timescale.create_db.sql which creates the user, associates password with it and fixes the __ error.

            Assignee:
            Shivam Kapila
            Reporter:
            Shivam Kapila
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Created:
              Updated:

                Version Package