Uploaded image for project: 'MusicBrainz Server'
  1. MusicBrainz Server
  2. MBS-8426

Install stalls on "cpanm --installdeps --notest ."

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Admin
    • Labels:
      None

      Description

      1. more /home/vm/.cpanm/work/1433415094.27207/build.log
        cpanm (App::cpanminus) 1.7001 on perl 5.018002 built for i686-linux-gnu-thread-multi-64int
        Work directory is /home/vm/.cpanm/work/1433415094.27207
        You have make /usr/bin/make
        You have LWP 6.13
        You have /bin/tar: tar (GNU tar) 1.27.1
        Copyright (C) 2013 Free Software Foundation, Inc.
        License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
        This is free software: you are free to change and redistribute it.
        There is NO WARRANTY, to the extent permitted by law.

      Written by John Gilmore and Jay Fenlason.
      Checking if you have ExtUtils::MakeMaker 6.31 ... Yes (7.04)
      Checking if you have ExtUtils::Install 1.46 ... Yes (1.59)
      --> Working on .
      Entering /home/musicbrainz/musicbrainz-server
      Configuring /home/musicbrainz/musicbrainz-server
      Running Makefile.PL
      -> FAIL Timed out (> 60s). Use --verbose to retry.
      -> N/A
      ! Configuring . failed. See /home/vm/.cpanm/work/1433415094.27207/build.log for details.

      with --verbose it stalls

      on ubuntu 14.04 -l libcatalyst*
      Desired=Unknown/Install/Remove/Purge/Hold

      Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
      / Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
      / Name Version Architecture Description
      +++===================================================================================================================
      un libcatalyst-actionrole-ac <none> <none> (no description available)
      ii libcatalyst-authenticatio 1.016-1 all HTTP Basic and Digest authentication for Catalyst
      ii libcatalyst-devel-perl 1.39-1 all collection of development tools for Catalyst
      ii libcatalyst-dispatchtype- 5.90033-2 all Regex DispatchType for Catalyst
      un libcatalyst-engine-apache <none> <none> (no description available)
      ii libcatalyst-modules-perl 47 all modules for Catalyst MVC Web Application Framework
      ii libcatalyst-perl 5.90053-1 all elegant Model-View-Controller Web Application Framework
      ii libcatalyst-plugin-cache- 0.001000-1 all HTTP/1.1 cache validators for Catalyst
      ii libcatalyst-plugin-sessio 0.05-1 all Memcached storage backend for session data
      un libcatalyst-plugin-unicod <none> <none> (no description available)
      ii libcatalyst-view-tt-perl 0.41-1 all Template View Class for Catalyst
      un libcatalystx-leakchecker- <none> <none> (no description available)
      un libcatalystx-simplelogin- <none> <none> (no description available)

      Is there some sort of lock on the perl installs ?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              arthurlutz Arthur Lutz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:

                Packages

                Version Package