Uploaded image for project: 'Picard'
  1. Picard
  2. PICARD-1707

macOS notarization requirements changed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Packaging & Deployment
    • Labels:
      None

      Description

      macOS notarization started to fail today. The reason it complains is that fpcalc was built with an SDK older then 10.9 [1].

      Turns out that Apple had relaxed the notarization requirements with the release of macOS Catalina temporarily till January, but now they are back enforcing all requirements [2]

      [1] https://osxapps-ssl.itunes.apple.com/itunes-assets/Enigma123/v4/bd/f9/c9/bdf9c9d1-28e0-3856-5d2f-4cc4a8167bde/developer_log.json?accessKey=1579213882_3050822637560889323_s0fINOGwgj3XvFXWLtGYTz95kwGfJPwq7QsQ%2FbRPX8hDttgVdX5UpVMipOVMwVSKrPv0nS%2BrZ%2F5VgMg1qgCExmM8XzL1W%2FPGvnuMDJZ9ZMaBTDGRu9H5sAJr%2B1xa82fcq2MGEaGqca2ztH3TlNmXaAfXZGAgl%2B6Jpro%2FMPBcrSA%3D
      [2] https://developer.apple.com/news/?id=09032019a

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                outsidecontext Philipp Wolfer
                Reporter:
                outsidecontext Philipp Wolfer
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Packages

                  Version Package