Uploaded image for project: 'Picard'
  1. Picard
  2. PICARD-1806

Broken Openssl dependencies Ubuntu 19.10

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Invalid
    • Affects Version/s: 2.3.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Description

      The issue is recognized as error by qt:

      qt.network.ssl: QSslSocket: cannot resolve CRYPTO_num_locks
      qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_id_callback
      qt.network.ssl: QSslSocket: cannot resolve CRYPTO_set_locking_callback
      qt.network.ssl: QSslSocket: cannot resolve ERR_free_strings
      qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_cleanup
      qt.network.ssl: QSslSocket: cannot resolve EVP_CIPHER_CTX_init
      qt.network.ssl: QSslSocket: cannot resolve sk_new_null
      qt.network.ssl: QSslSocket: cannot resolve sk_push
      qt.network.ssl: QSslSocket: cannot resolve sk_free
      qt.network.ssl: QSslSocket: cannot resolve sk_num
      qt.network.ssl: QSslSocket: cannot resolve sk_pop_free
      qt.network.ssl: QSslSocket: cannot resolve sk_value
      qt.network.ssl: QSslSocket: cannot resolve SSL_library_init
      qt.network.ssl: QSslSocket: cannot resolve SSL_load_error_strings
      qt.network.ssl: QSslSocket: cannot resolve SSL_get_ex_new_index
      qt.network.ssl: QSslSocket: cannot resolve SSLv3_client_method
      qt.network.ssl: QSslSocket: cannot resolve SSLv23_client_method
      qt.network.ssl: QSslSocket: cannot resolve SSLv3_server_method
      qt.network.ssl: QSslSocket: cannot resolve SSLv23_server_method
      qt.network.ssl: QSslSocket: cannot resolve X509_STORE_CTX_get_chain
      qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
      qt.network.ssl: QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
      qt.network.ssl: QSslSocket: cannot resolve SSLeay
      qt.network.ssl: QSslSocket: cannot resolve SSLeay_version
      qt.network.ssl: QSslSocket: cannot call unresolved function SSLeay
      qt.network.ssl: Incompatible version of OpenSSL
      defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"
      W: 13:08:12,912 /usr/lib/picard/picard/ui/playertoolbar.__init__:102: Internal player: unavailable, service is missing
      qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
      qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
      

      If you try to request or analyze a title or a group the apllication can't get a connection to musicbrainz. I have used a test file in this case after grouping.

      W: 13:08:12,912 /usr/lib/picard/picard/ui/playertoolbar.__init__:102: Internal player: unavailable, service is missing
      qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
      qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
      E: 13:08:41,874 /usr/lib/picard/picard/webservice/__init__._handle_reply:396: Network request error for https://musicbrainz.org:443/ws/2/release?limit=25&query=artist%3A%28music%29 release%3A%28axel hacke deutschland%29 tracks%3A%283%29: Es konnte keine SSL-Kontextstruktur erzeugt werden (error:140A90C4:SSL routines:func(169):reason(196)) (QT code 99, HTTP code 0)
      qt.network.ssl: QSslSocket: cannot call unresolved function SSLv23_client_method
      qt.network.ssl: QSslSocket: cannot call unresolved function SSL_library_init
      E: 13:08:46,512 /usr/lib/picard/picard/webservice/__init__._handle_reply:396: Network request error for https://musicbrainz.org:443/ws/2/release?limit=25&query=artist%3A%28music%29 release%3A%28axel hacke deutschland%29 tracks%3A%283%29: Es konnte keine SSL-Kontextstruktur erzeugt werden (error:140A90C4:SSL routines:func(169):reason(196)) (QT code 99, HTTP code 0)
      

      This stackflow question may be related to this.

      It seems like this line:

      qt.network.ssl: Incompatible version of OpenSSL

      contains the essential error. It seems like a newer or older version is required. This should be specified in the package dependencies in the repo.

      Package infos:

      # sudo apt show openssl
      
      Package: openssl
      Version: 1.1.1c-1ubuntu4
      Priority: important
      Section: utils
      Origin: Ubuntu
      Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
      Original-Maintainer: Debian OpenSSL Team <pkg-openssl-devel@lists.alioth.debian.org>
      Bugs: https://bugs.launchpad.net/ubuntu/+filebug
      Installed-Size: 1.282 kB
      Depends: libc6 (>= 2.15), libssl1.1 (>= 1.1.1)
      Suggests: ca-certificates
      Homepage: https://www.openssl.org/
      Task: minimal, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages
      Supported: 9m
      Download-Size: 619 kB
      APT-Manual-Installed: yes
      APT-Sources: http://de.archive.ubuntu.com/ubuntu eoan/main amd64 Packages
      Description: Secure Sockets Layer toolkit - cryptographic utility
       This package is part of the OpenSSL project's implementation of the SSL
       and TLS cryptographic protocols for secure communication over the
       Internet.
       .
       It contains the general-purpose command line binary /usr/bin/openssl,
       useful for cryptographic operations such as:
        * creating RSA, DH, and DSA key parameters;
        * creating X.509 certificates, CSRs, and CRLs;
        * calculating message digests;
        * encrypting and decrypting with ciphers;
        * testing SSL/TLS clients and servers;
        * handling S/MIME signed or encrypted mail.
      
      # sudo apt show libssl1.1
      
      # Package: libssl1.1
      Version: 1.1.1c-1ubuntu4
      Priority: important
      Section: libs
      Source: openssl
      Origin: Ubuntu
      Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
      Original-Maintainer: Debian OpenSSL Team <pkg-openssl-devel@lists.alioth.debian.org>
      Bugs: https://bugs.launchpad.net/ubuntu/+filebug
      Installed-Size: 4.110 kB
      Depends: libc6 (>= 2.25), debconf (>= 0.5) | debconf-2.0
      Breaks: isync (<< 1.3.0-2), lighttpd (<< 1.4.49-2), python-boto (<< 2.44.0-1.1), python-httplib2 (<< 0.11.3-1), python-imaplib2 (<< 2.57-5), python3-boto (<< 2.44.0-1.1), python3-imaplib2 (<< 2.57-5)
      Homepage: https://www.openssl.org/
      Task: minimal, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-minimal-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages, ubuntu-desktop-default-languages
      Supported: 9m
      Download-Size: 1.314 kB
      APT-Manual-Installed: no
      APT-Sources: http://de.archive.ubuntu.com/ubuntu eoan/main amd64 Packages
      Description: Secure Sockets Layer toolkit - shared libraries
       This package is part of the OpenSSL project's implementation of the SSL
       and TLS cryptographic protocols for secure communication over the
       Internet.
       .
       It provides the libssl and libcrypto shared libraries.
      
      
      
      # sudo apt show libqt5network5
      
      Package: libqt5network5
      Version: 5.12.4+dfsg-4ubuntu1.1
      Priority: optional
      Section: universe/libs
      Source: qtbase-opensource-src
      Origin: Ubuntu
      Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
      Original-Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
      Bugs: https://bugs.launchpad.net/ubuntu/+filebug
      Installed-Size: 2.685 kB
      Depends: libssl1.1, libc6 (>= 2.14), libqt5core5a (>= 5.12.2), libqt5dbus5 (>= 5.0.2), libstdc++6 (>= 5), qtbase-abi-5-12-4, zlib1g (>= 1:1.1.4)
      Homepage: https://www.qt.io/developers/
      Task: kubuntu-desktop, lubuntu-desktop, ubuntustudio-desktop-core, ubuntustudio-desktop, ubuntukylin-desktop, ubuntu-mate-core, ubuntu-mate-desktop, ubuntu-budgie-desktop
      Download-Size: 673 kB
      APT-Manual-Installed: no
      APT-Sources: http://de.archive.ubuntu.com/ubuntu eoan-updates/universe amd64 Packages
      Description: Qt 5 network module
       Qt is a cross-platform C++ application framework. Qt's primary feature
       is its rich set of widgets that provide standard GUI functionality.
       .
       The QtNetwork module offers classes that allow you to write TCP/IP clients and
       servers. It provides classes to make network programming easier and portable.
      
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Cobalt Cobalt
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Packages

                Version Package