Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: None
    • Labels:

      Description

      Picard 1.x is using PyQt4 for its UI and a lot of other things. The most recent PyQt is 5(.7) and upstream PyQt «no longer supports Qt v4. PyQt5 and Qt v5 are strongly recommended for all new development.» Picard isn't quite "new development", but it does mean that we should likely switch when we can. And Picard 2.0 is a good candidate for this.

      There also seems to be general consensus about this when it's been brought up/mentioned on IRC/#metabrainz and I haven't noticed anyone speaking out against it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                samj1912 Sambhav Kothari
                Reporter:
                freso Frederik “Freso” S. Olesen
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: