Uploaded image for project: 'Picard Website'
  1. Picard Website
  2. PW-27

Don't list incompatible plugins in the API

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Labels:
      None

      Description

      This is related to https://github.com/metabrainz/picard-plugins/issues/64.

      At the moment, the plugins API lists plugin versions that are not compatible with the version of Picard calling the API/most recent released version of Picard.

      This should be fixed by either

      • not listing plugins incompatible with the most recent released version in the API and/or
      • having different lists and API endpoints for stable and unstable versions and/or
      • having Picard send a list of supported PLUGIN_API_VERSIONS along and dynamically building the plugin list based on that

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                dufferzafar Shadab Zafar
                Reporter:
                mineo Wieland Hoffmann
              • Votes:
                1 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:

                  Packages

                  Version Package